Incident affecting job scheduling

Incident Report for Spacelift

Resolved

The system has been operating normally since the backlog cleared. Events are being processed correctly and runs are now being scheduled normally.
Posted Sep 16, 2022 - 19:42 UTC

Monitoring

We experienced a backlog on our event processing system, leading to a delay in messages being processed. This affected job scheduling and sending notifications to VCS providers. As of 18:57 UTC, the backlog cleared and runs began scheduling normally again. We are currently monitoring to make sure the incident has completely resolved.
Posted Sep 16, 2022 - 19:19 UTC

Investigating

We are currently investigating an issue that is preventing runs from being scheduled correctly. This may prevent runs triggering or may cause runs to take longer than usual to start.
Posted Sep 16, 2022 - 18:46 UTC
This incident affected: Event processing and Public workers.