Degraded performance related to ignored run warnings

Incident Report for Spacelift

Resolved

We are continuing to monitor the system performance and have decided to continue to keep the ignored run warnings feature disabled temporarily. We are resolving this incident for now, and will aim to re-enable the feature as soon as possible.
Posted Feb 06, 2025 - 14:39 UTC

Monitoring

We have identified an edge-case in the ignored run warnings feature that may impact system performance. While we are investigating and attempting to fix this issue, we have temporarily disabled the feature. While the feature is disabled we will not display information about why runs were not triggered or why stacks are not in sync with the latest commit. We will continue to investigate the situation and will provide an update as soon as we have more information.
Posted Feb 06, 2025 - 10:41 UTC
This incident affected: GraphQL API, Event processing, and Platform UI.