Environment disruptions (app.us.spacelift.io)

Incident Report for Spacelift

Resolved

The issue has been resolved
Posted Mar 16, 2026 - 20:03 UTC

Update

We are still facing ongoing issues with stuck runs in our US environment and are working on automatic remediation.
Posted Mar 16, 2026 - 17:51 UTC

Update

We identified an infrastructure change that caused disruptions for US accounts, including workers disconnecting from Spacelift and webhook-triggered runs not being processed.

The main issue has been resolved, and message processing has recovered. Only customers in the US region were impacted.
Posted Mar 16, 2026 - 17:09 UTC

Monitoring

We identified that an infrastructure change resulting in disruptions for US accounts, such as workers disconnecting from Spacelift and webhook-triggered runs not being processed.

The main issue has been resolved, and message processing has recovered. Only US region customers were impacted.
Posted Mar 16, 2026 - 16:24 UTC